Get in touch
Back
Maintenance

Billing system upgrade

Completed 13 Sep at 10:00pm PDT.

Speakbox Care
Completed

Maintenance completed

Posted 13 Sep at 10:00pm PDT.
Started

Billing systems will be undergoing an upgrade. During this period, you may experience disruptions for billing-related features.

Please contact support@speakbox.ca if you notice anything regarding your account billing.

Posted 13 Sep at 09:00pm PDT.