Get in touch
Back
Maintenance

System upgrade

Completed 30 Sep at 01:30am PDT.

Speakbox Life Speakbox Care Authentication Service Billing Service Calendar Service
Completed

Posted 30 Sep at 01:30am PDT.
Started

We will be performing a system upgrade and database migration related to referrals/client directory.

We recommend avoiding interactions with the Client Directory during this time.

For more information, contact us at support@speakbox.ca.

Posted 29 Sep at 11:00pm PDT.