Get in touch
Back
Maintenance

Database Migration

Completed 6 Feb at 06:31am PST.

Speakbox Life Speakbox Care
Completed

Database upgrade completed. Please report any issues experience to support@speakbox.ca. Enjoy 😃

Posted 6 Feb at 06:31am PST.
Started

In order to increase stability and reliability as well as accelerating development, Speakbox will undergo a full database migration. Since it is a significant upgrade, please contact support@speakbox.ca if you are experiencing any issues and we will work to resolve it as fast as possible.

Posted 5 Feb at 10:00pm PST.