Get in touch
Back
Maintenance

UI Updates

Completed 17 Mar at 09:00pm PDT.

Speakbox Life Speakbox Care
Completed

Maintenance completed

Posted 17 Mar at 09:00pm PDT.
Started

We will be deploying various updates related to the user interface, for both Speakbox Care and Speakbox Life. Applications will remain accessible, though partial outage is possible.

Posted 17 Mar at 08:00pm PDT.